Setting static IP address on Bipac 8800AXL R2 fails

Discussions for BiPAC 8800 series: 8800NL
Post Reply
Ksaro1
Posts: 34
Joined: Wed Oct 24, 2018 10:34 am

Setting static IP address on Bipac 8800AXL R2 fails

Post by Ksaro1 » Thu Oct 31, 2019 1:21 pm

I've recently purchased a Raspberry Pi 4 that I was wanting to configure as a web server. The first thing that I need to ensure is that it has a static IP address within my home network. However, when I added its MAC address to be given a static IP address Configuration -> Lan -> Static IP Lease List, it kept being given an IP address in the DHCP range of 100-199 and it didn't get added to the home.gateway domain. When I removed its static IP entry to return to the original Bipac configuration, then it still wasn't being added to the home.gateway domain and it didn't show under the Status -> DHCP listings. I have rebooted both the Bipac router and the Pi several times. The Pi is connecting to the network wirelessly under 5G via a guest SSID.

The Pi can now seen on the network as raspberrypi.local, when before I made the changes it was seen as raspberrypi.home.gateway and it was listed in the DHCP listings under the hostname of raspberrypi. Now there is no entry at all for this device in the DHCP listings.

billion_fan
Posts: 5224
Joined: Tue Jul 19, 2011 4:30 pm

Re: Setting static IP address on Bipac 8800AXL R2 fails

Post by billion_fan » Thu Oct 31, 2019 1:33 pm

Ksaro1 wrote:
Thu Oct 31, 2019 1:21 pm
I've recently purchased a Raspberry Pi 4 that I was wanting to configure as a web server. The first thing that I need to ensure is that it has a static IP address within my home network. However, when I added its MAC address to be given a static IP address Configuration -> Lan -> Static IP Lease List, it kept being given an IP address in the DHCP range of 100-199 and it didn't get added to the home.gateway domain. When I removed its static IP entry to return to the original Bipac configuration, then it still wasn't being added to the home.gateway domain and it didn't show under the Status -> DHCP listings. I have rebooted both the Bipac router and the Pi several times. The Pi is connecting to the network wirelessly under 5G via a guest SSID.

The Pi can now seen on the network as raspberrypi.local, when before I made the changes it was seen as raspberrypi.home.gateway and it was listed in the DHCP listings under the hostname of raspberrypi. Now there is no entry at all for this device in the DHCP listings.
Check the ARP list for your PI,

There are no issues with Static IP Lease List that I am aware of, you can test it with a PC, once the static IP lease is added (MAC and IP), release and renew the IP address on the PC and you will see the new IP address,

Update

I just ran a quick test here, connected a laptop to the guest 5g network (no group isolation), got a normal 192.168.1.101, then added the MAC and IP within the static lease list, released and renewed the IP on the laptop, I got the new IP address 192.168.1.206, laptop also shown within the DHCP table with new IP 192.168.1.206, so all working here

Ksaro1
Posts: 34
Joined: Wed Oct 24, 2018 10:34 am

Re: Setting static IP address on Bipac 8800AXL R2 fails

Post by Ksaro1 » Fri Nov 01, 2019 8:59 am

billion_fan wrote:
Thu Oct 31, 2019 1:33 pm
Check the ARP list for your PI,

There are no issues with Static IP Lease List that I am aware of, you can test it with a PC, once the static IP lease is added (MAC and IP), release and renew the IP address on the PC and you will see the new IP address,

Update

I just ran a quick test here, connected a laptop to the guest 5g network (no group isolation), got a normal 192.168.1.101, then added the MAC and IP within the static lease list, released and renewed the IP on the laptop, I got the new IP address 192.168.1.206, laptop also shown within the DHCP table with new IP 192.168.1.206, so all working here
Thanks for the reply.

I checked my Pi and discovered that somehow, probably from one installation or another, the IP address of the Pi was set to a static one, in the DHCP range of the Billion, on the Pi's network interface configuration? So, I re-set this on the Pi to the static IP address set on the Billion and all now works as expected.

Another question though : the static IP address's hostname is now in the .local domain. The devices that are given a DHCP address are in the .home.gateway domain. Is there any way to set the hosts to all be in the same domain?

billion_fan
Posts: 5224
Joined: Tue Jul 19, 2011 4:30 pm

Re: Setting static IP address on Bipac 8800AXL R2 fails

Post by billion_fan » Fri Nov 01, 2019 9:16 am

Ksaro1 wrote:
Fri Nov 01, 2019 8:59 am
billion_fan wrote:
Thu Oct 31, 2019 1:33 pm
Check the ARP list for your PI,

There are no issues with Static IP Lease List that I am aware of, you can test it with a PC, once the static IP lease is added (MAC and IP), release and renew the IP address on the PC and you will see the new IP address,

Update

I just ran a quick test here, connected a laptop to the guest 5g network (no group isolation), got a normal 192.168.1.101, then added the MAC and IP within the static lease list, released and renewed the IP on the laptop, I got the new IP address 192.168.1.206, laptop also shown within the DHCP table with new IP 192.168.1.206, so all working here
Thanks for the reply.

I checked my Pi and discovered that somehow, probably from one installation or another, the IP address of the Pi was set to a static one, in the DHCP range of the Billion, on the Pi's network interface configuration? So, I re-set this on the Pi to the static IP address set on the Billion and all now works as expected.

Another question though : the static IP address's hostname is now in the .local domain. The devices that are given a DHCP address are in the .home.gateway domain. Is there any way to set the hosts to all be in the same domain?
Its hard to comment as I don't have a PI to run tests.

What you can try is setting the PI to obtain a IP/DNS address automatically, and let the router assign the IP address via DHCP/Static IP lease, just like before.

evansnp
Posts: 162
Joined: Fri Feb 28, 2014 11:28 am

Re: Setting static IP address on Bipac 8800AXL R2 fails

Post by evansnp » Mon Nov 04, 2019 12:05 pm

I set all of my Raspberry PIs to DCHP, as Billion_Fan suggested, and then hand them a static address from the router. This is a better way to do it, as you don't have to go around every device if you change your network setup.

Post Reply