Page 1 of 1

DNS-O-Matic

Posted: Fri Mar 19, 2021 2:34 am
by pstonethompson
I am having the same issue described at Three reboots in 24 hours with a BiPAC 8900AX2400 running firmware 2.52.d46. The last successful update received by DNS-O-Matic was on the second of March, with no changes to the router or credentials to have caused it. I am getting continuous failed update attempts in the logs. It appears that either this filling the logs or possibly some kind of memory leak (possibly with the HTTP client?) is causing the router to reboot a few times a day.

Re-entering the credentials did not make any difference, still constant failed updates.

I have for now removed the dynamic DNS service.

Re: DNS-O-Matic

Posted: Fri Mar 19, 2021 11:14 am
by billion_fan
pstonethompson wrote:
Fri Mar 19, 2021 2:34 am
I am having the same issue described at Three reboots in 24 hours with a BiPAC 8900AX2400 running firmware 2.52.d46. The last successful update received by DNS-O-Matic was on the second of March, with no changes to the router or credentials to have caused it. I am getting continuous failed update attempts in the logs. It appears that either this filling the logs or possibly some kind of memory leak (possibly with the HTTP client?) is causing the router to reboot a few times a day.

Re-entering the credentials did not make any difference, still constant failed updates.

I have for now removed the dynamic DNS service.
I'll request the firmware fix for the 8900 series

Re: DNS-O-Matic

Posted: Tue Mar 23, 2021 11:21 am
by billion_fan
billion_fan wrote:
Fri Mar 19, 2021 11:14 am
pstonethompson wrote:
Fri Mar 19, 2021 2:34 am
I am having the same issue described at Three reboots in 24 hours with a BiPAC 8900AX2400 running firmware 2.52.d46. The last successful update received by DNS-O-Matic was on the second of March, with no changes to the router or credentials to have caused it. I am getting continuous failed update attempts in the logs. It appears that either this filling the logs or possibly some kind of memory leak (possibly with the HTTP client?) is causing the router to reboot a few times a day.

Re-entering the credentials did not make any difference, still constant failed updates.

I have for now removed the dynamic DNS service.
I'll request the firmware fix for the 8900 series
Attached are newer firmware versions for the Bipac 8900AX-2400 and Bipac 8900AX-1600R2 which resolves connectivity issues with DNS-O-Matic

Re: DNS-O-Matic

Posted: Tue Mar 23, 2021 10:54 pm
by ittroll
billion_fan wrote:
Tue Mar 23, 2021 11:21 am
Attached are newer firmware versions for the Bipac 8900AX-2400 and Bipac 8900AX-1600R2 which resolves connectivity issues with DNS-O-Matic
I tried Zcomax8900AX-R2_2.52.d4_ddns2.afw on my 8900AX-1600R2 but I get failures.

Code: Select all

Mar 23 22:01:17 user info syslog: ddnsd: all.dnsomatic.com (ptm0.2) IP has changed from (null) to 12.34.56.78
Mar 23 22:01:17 user info syslog: ddnsd: update all.dnsomatic.com request failed. Please check the setting.
I rolled back to the previous Zcomax8900AX-R2_2.52.d4.afw release but that gives the same error.

As far as I can tell the update URL hasn't changed. I can successfully authenticate and update via a browser by using:

Code: Select all

https://updates.dnsomatic.com:443/nic/update?hostname=all.dnsomatic.com
I noticed the API docs talk about the importance of using a well-formed User-Agent string. Which of course a browser will do.
https://www.dnsomatic.com/docs/api

It would be more helpful if the syslog logged the full return code from the DNS-O-Matic API.

Re: DNS-O-Matic

Posted: Wed Mar 24, 2021 9:14 am
by billion_fan
ittroll wrote:
Tue Mar 23, 2021 10:54 pm
billion_fan wrote:
Tue Mar 23, 2021 11:21 am
Attached are newer firmware versions for the Bipac 8900AX-2400 and Bipac 8900AX-1600R2 which resolves connectivity issues with DNS-O-Matic
I tried Zcomax8900AX-R2_2.52.d4_ddns2.afw on my 8900AX-1600R2 but I get failures.

Code: Select all

Mar 23 22:01:17 user info syslog: ddnsd: all.dnsomatic.com (ptm0.2) IP has changed from (null) to 12.34.56.78
Mar 23 22:01:17 user info syslog: ddnsd: update all.dnsomatic.com request failed. Please check the setting.
I rolled back to the previous Zcomax8900AX-R2_2.52.d4.afw release but that gives the same error.

As far as I can tell the update URL hasn't changed. I can successfully authenticate and update via a browser by using:

Code: Select all

https://updates.dnsomatic.com:443/nic/update?hostname=all.dnsomatic.com
I noticed the API docs talk about the importance of using a well-formed User-Agent string. Which of course a browser will do.
https://www.dnsomatic.com/docs/api

It would be more helpful if the syslog logged the full return code from the DNS-O-Matic API.
Newer firmware's have been added above :D

Re: DNS-O-Matic

Posted: Tue Mar 30, 2021 11:58 pm
by ittroll
billion_fan wrote:
Wed Mar 24, 2021 9:14 am
Newer firmware's have been added above :D
Ah, I missed that these had been reposted. I think because you edited an old post and so no post notification was sent.

DNS updates are indeed working again on 8900AX-1600R2. Many thanks to you and the engineering team. :D