Bipac 8800AXL R2 does not return hostname for static IP address on Ethernet port

Discussions for BiPAC 8800 series: 8800NL
Post Reply
Ksaro1
Posts: 33
Joined: Wed Oct 24, 2018 10:34 am

Bipac 8800AXL R2 does not return hostname for static IP address on Ethernet port

Post by Ksaro1 » Wed Mar 03, 2021 12:47 pm

I have a Raspberry Pi 4 connected to my Bipac router via Ethernet. I am using this Pi as an external Web server so I have set a static IP address on the Bipac for it. However, I now find that on machines attached to my local WAN and LAN that they can't access the Pi by hostname. They can only access it by IP address. I have configured all devices on my local network to use the Bipac as their DNS server.

I have set the IP address of my Pi 4 to 192.168.1.11 and I get the following on a typical machine on my local network:

$ dig raspberrypi

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> raspberrypi
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 11049
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;raspberrypi. IN A

;; AUTHORITY SECTION:
. 85800 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2021030300 1800 900 604800 86400

;; Query time: 30 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:25:11 GMT 2021
;; MSG SIZE rcvd: 115

$ dig -x 192.168.1.11

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> -x 192.168.1.11
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 45157
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;11.1.168.192.in-addr.arpa. IN PTR

;; Query time: 30 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:36:42 GMT 2021
;; MSG SIZE rcvd: 54

Because I've put the IP address of the Pi 4 in some machines' /etc/hosts files I do get the following:

$ ping -c 3 raspberrypi
PING raspberrypi (192.168.1.11) 56(84) bytes of data.
64 bytes from raspberrypi (192.168.1.11): icmp_seq=1 ttl=64 time=1.68 ms
64 bytes from raspberrypi (192.168.1.11): icmp_seq=2 ttl=64 time=1.75 ms
64 bytes from raspberrypi (192.168.1.11): icmp_seq=3 ttl=64 time=1.93 ms

--- raspberrypi ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 5ms
rtt min/avg/max/mdev = 1.678/1.786/1.929/0.115 ms

But, not all machines support a hosts file. Also, why do I have to manually add this in the first place?

Here are 2 example hosts on the same home network, one on the WAN and one on the Ethernet LAN -

$ dig PiTv
;; Warning: Message parser reports malformed message packet.

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> PiTv
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4902
;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: 8a7f0d308fabdf6c (echoed)
;; QUESTION SECTION:
;PiTv. IN A

;; ADDITIONAL SECTION:
PiTv. 162108 IN A 192.168.1.113

;; Query time: 0 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:40:13 GMT 2021
;; MSG SIZE rcvd: 61

$ dig alexs-imac
;; Warning: Message parser reports malformed message packet.

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> alexs-imac
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34928
;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: a8e14bee4f5e255b (echoed)
;; QUESTION SECTION:
;alexs-imac. IN A

;; ADDITIONAL SECTION:
alexs-imac. 162125 IN A 192.168.1.115

;; Query time: 3 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:40:29 GMT 2021
;; MSG SIZE rcvd: 67

Any idea why the Bipac isn't resolving the static IP address of an attached device to its hostname?

billion_fan
Posts: 5210
Joined: Tue Jul 19, 2011 4:30 pm

Re: Bipac 8800AXL R2 does not return hostname for static IP address on Ethernet port

Post by billion_fan » Wed Mar 03, 2021 3:50 pm

Ksaro1 wrote:
Wed Mar 03, 2021 12:47 pm
I have a Raspberry Pi 4 connected to my Bipac router via Ethernet. I am using this Pi as an external Web server so I have set a static IP address on the Bipac for it. However, I now find that on machines attached to my local WAN and LAN that they can't access the Pi by hostname. They can only access it by IP address. I have configured all devices on my local network to use the Bipac as their DNS server.

I have set the IP address of my Pi 4 to 192.168.1.11 and I get the following on a typical machine on my local network:

$ dig raspberrypi

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> raspberrypi
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 11049
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;raspberrypi. IN A

;; AUTHORITY SECTION:
. 85800 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2021030300 1800 900 604800 86400

;; Query time: 30 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:25:11 GMT 2021
;; MSG SIZE rcvd: 115

$ dig -x 192.168.1.11

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> -x 192.168.1.11
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 45157
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;11.1.168.192.in-addr.arpa. IN PTR

;; Query time: 30 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:36:42 GMT 2021
;; MSG SIZE rcvd: 54

Because I've put the IP address of the Pi 4 in some machines' /etc/hosts files I do get the following:

$ ping -c 3 raspberrypi
PING raspberrypi (192.168.1.11) 56(84) bytes of data.
64 bytes from raspberrypi (192.168.1.11): icmp_seq=1 ttl=64 time=1.68 ms
64 bytes from raspberrypi (192.168.1.11): icmp_seq=2 ttl=64 time=1.75 ms
64 bytes from raspberrypi (192.168.1.11): icmp_seq=3 ttl=64 time=1.93 ms

--- raspberrypi ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 5ms
rtt min/avg/max/mdev = 1.678/1.786/1.929/0.115 ms

But, not all machines support a hosts file. Also, why do I have to manually add this in the first place?

Here are 2 example hosts on the same home network, one on the WAN and one on the Ethernet LAN -

$ dig PiTv
;; Warning: Message parser reports malformed message packet.

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> PiTv
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4902
;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: 8a7f0d308fabdf6c (echoed)
;; QUESTION SECTION:
;PiTv. IN A

;; ADDITIONAL SECTION:
PiTv. 162108 IN A 192.168.1.113

;; Query time: 0 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:40:13 GMT 2021
;; MSG SIZE rcvd: 61

$ dig alexs-imac
;; Warning: Message parser reports malformed message packet.

; <<>> DiG 9.11.5-P4-5.1+deb10u3-Raspbian <<>> alexs-imac
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34928
;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: a8e14bee4f5e255b (echoed)
;; QUESTION SECTION:
;alexs-imac. IN A

;; ADDITIONAL SECTION:
alexs-imac. 162125 IN A 192.168.1.115

;; Query time: 3 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Wed Mar 03 12:40:29 GMT 2021
;; MSG SIZE rcvd: 67

Any idea why the Bipac isn't resolving the static IP address of an attached device to its hostname?
Add a another rule under 'Advanced >> DNS >> Static DNS'

Example attached
You do not have the required permissions to view the files attached to this post.

Ksaro1
Posts: 33
Joined: Wed Oct 24, 2018 10:34 am

Re: Bipac 8800AXL R2 does not return hostname for static IP address on Ethernet port

Post by Ksaro1 » Thu Mar 04, 2021 3:39 pm

Bingo! That did the trick. Thanks.

Post Reply