Private DNS not working on Android

Discussions for BiPAC 8800 series: 8800NL
Post Reply
tripleblue2
Posts: 4
Joined: Tue Jan 28, 2020 3:00 pm

Private DNS not working on Android

Post by tripleblue2 » Tue Jan 28, 2020 3:59 pm

Hi. I've recently purchased the 8800 AXL R2 router, love it so far.

I've come across one issue and I'm not sure how to resolve it, would love some help.

Basically I'm trying to setup DNS-over-TLS on my android, the setting is as simple as you go to Settings>More Connection Settings>Private DNS and I set it to:
dns.google

as according to https://developers.google.com/speed/pub ... docs/using

Now with my old router, this worked fine. However now when I enable this DNS on my android, I have no internet connection. If I disable it, internet works fine.

Does anyone have any idea which setting on the router is blocking this? Thank you.

billion_fan
Posts: 5176
Joined: Tue Jul 19, 2011 4:30 pm

Re: Private DNS not working on Android

Post by billion_fan » Tue Jan 28, 2020 4:24 pm

tripleblue2 wrote:
Tue Jan 28, 2020 3:59 pm
Hi. I've recently purchased the 8800 AXL R2 router, love it so far.

I've come across one issue and I'm not sure how to resolve it, would love some help.

Basically I'm trying to setup DNS-over-TLS on my android, the setting is as simple as you go to Settings>More Connection Settings>Private DNS and I set it to:
dns.google

as according to https://developers.google.com/speed/pub ... docs/using

Now with my old router, this worked fine. However now when I enable this DNS on my android, I have no internet connection. If I disable it, internet works fine.

Does anyone have any idea which setting on the router is blocking this? Thank you.
Just tested with admin's One plus five T, android version 9, and everything worked fine, when connecting to the 8800AXLR2, we could still browse the internet. (we also set the Private DNS to dns.google)

So it must be something else

tripleblue2
Posts: 4
Joined: Tue Jan 28, 2020 3:00 pm

Re: Private DNS not working on Android

Post by tripleblue2 » Tue Jan 28, 2020 4:37 pm

It has to be something router based as when I plug in the old router in, (TP Link VR400), the private dns works fine.

Perhaps there is some function that I've enabled or disabled on the router that causes it not to work on my android? I've set manually dns on the router itself to 8.8.8.8 and 8.8.4.4 wherever possible, and I've disabled DNS Proxy. I've also checked things like
Parameters
Wireless Enable
Hide SSID Enable
Clients Isolation Enable
Disable WMM Advertise Enable

Any ideas?

Thanks for the quick answer btw!

billion_fan
Posts: 5176
Joined: Tue Jul 19, 2011 4:30 pm

Re: Private DNS not working on Android

Post by billion_fan » Tue Jan 28, 2020 4:47 pm

tripleblue2 wrote:
Tue Jan 28, 2020 4:37 pm
It has to be something router based as when I plug in the old router in, (TP Link VR400), the private dns works fine.

Perhaps there is some function that I've enabled or disabled on the router that causes it not to work on my android? I've set manually dns on the router itself to 8.8.8.8 and 8.8.4.4 wherever possible, and I've disabled DNS Proxy. I've also checked things like
Parameters
Wireless Enable
Hide SSID Enable
Clients Isolation Enable
Disable WMM Advertise Enable

Any ideas?

Thanks for the quick answer btw!
Try enabling the DNS proxy option within the router

tripleblue2
Posts: 4
Joined: Tue Jan 28, 2020 3:00 pm

Re: Private DNS not working on Android

Post by tripleblue2 » Tue Jan 28, 2020 4:51 pm

Tried it, restarted the router and phone, still didn't work. What about in WAN settings I've enabled "Static DNS" which I've set to 8.8.8.8 and 8.8.4.4. Would it be possible that this for example blocks any other DNS from even working on my network? The other option for this would be "Use Wan Interface"

billion_fan
Posts: 5176
Joined: Tue Jul 19, 2011 4:30 pm

Re: Private DNS not working on Android

Post by billion_fan » Tue Jan 28, 2020 4:55 pm

tripleblue2 wrote:
Tue Jan 28, 2020 4:51 pm
Tried it, restarted the router and phone, still didn't work. What about in WAN settings I've enabled "Static DNS" which I've set to 8.8.8.8 and 8.8.4.4. Would it be possible that this for example blocks any other DNS from even working on my network? The other option for this would be "Use Wan Interface"
That should not be the issue, as these are google DNS servers also.

For a test you can try setting static DNS severs to a device connected to the router, all it will do is use the DNS server set on the device (override what is set on the router)

billion_fan
Posts: 5176
Joined: Tue Jul 19, 2011 4:30 pm

Re: Private DNS not working on Android

Post by billion_fan » Tue Jan 28, 2020 5:01 pm

billion_fan wrote:
Tue Jan 28, 2020 4:55 pm
tripleblue2 wrote:
Tue Jan 28, 2020 4:51 pm
Tried it, restarted the router and phone, still didn't work. What about in WAN settings I've enabled "Static DNS" which I've set to 8.8.8.8 and 8.8.4.4. Would it be possible that this for example blocks any other DNS from even working on my network? The other option for this would be "Use Wan Interface"
That should not be the issue, as these are google DNS servers also.

For a test you can try setting static DNS severs to a device connected to the router, all it will do is use the DNS server set on the device (override what is set on the router)
Just tested it again, set the my 8800AXLR2 to 8.8.8.8 and 8.8.4.4 (static DNS entry for the WAN), enabled client isolation on the 2.4ghz band, everything else left on default and still able to browse the internet once we enabled Private DNS on the One Plus

tripleblue2
Posts: 4
Joined: Tue Jan 28, 2020 3:00 pm

Re: Private DNS not working on Android

Post by tripleblue2 » Tue Jan 28, 2020 5:08 pm

Hi, I apologise, my bad, it was actually the DNS Proxy that was causing this not to work. I've enabled it and it works private dns works fine now, if I disable it, it doesn't work anymore.

Would you be able to explain to me what exactly DNS Proxy does - why is it good, or bad to have it? I did simple Google search and decided to disable it as most users it's not needed and that routers shouldn't be in this way but they did not give any technical details so I still have no idea about it.

Thank you.

billion_fan
Posts: 5176
Joined: Tue Jul 19, 2011 4:30 pm

Re: Private DNS not working on Android

Post by billion_fan » Tue Jan 28, 2020 5:17 pm

tripleblue2 wrote:
Tue Jan 28, 2020 5:08 pm
Hi, I apologise, my bad, it was actually the DNS Proxy that was causing this not to work. I've enabled it and it works private dns works fine now, if I disable it, it doesn't work anymore.

Would you be able to explain to me what exactly DNS Proxy does - why is it good, or bad to have it? I did simple Google search and decided to disable it as most users it's not needed and that routers shouldn't be in this way but they did not give any technical details so I still have no idea about it.

Thank you.
Extract from the manual. (I would leave it enabled, or you will run into issues)

DNS proxy is used to forward requests and response messages between DNS Clients and DNS Servers.
Hosts in LAN can use a router serving as a DNS proxy to connect to the DNS Server in public to
correctly resolve Domain name to access the internet.

Post Reply