Wake on LAN (WOL) Problems

Post Reply
transparentdesigns
Posts: 3
Joined: Sat Jan 14, 2012 7:29 pm
Location: Brighton, UK
Contact:

Wake on LAN (WOL) Problems

Post by transparentdesigns » Sun Jan 15, 2012 6:01 pm

I recently purchased a BiPAC 7800N router which so far has been fantastic. However, I'm having problems getting WOL to work over the internet in order to use VNC. The web interface offers a dedicated Wake on LAN setting and I've tried putting in the MAC address of my computer but this doesn't to work. I can wake the PC up from within the LAN - but no luck via the Internet.

I use DynDNS - and when the PC is turned on I'm able to connect via VNC from outside the LAN so that side works. It just seems that when I send the magic packet it's not being forwarded on to the PC.

I tried under Virtual Server, Port Mapping UDP 9 to the PC (which has a fixed IP on the LAN) - as I read somewhere to try this. But I also read that as the PC is off, it doesn't in effect have an IP so this wouldn't work. Another article I read said to forward to 192.168.1.255 - the broadcast address - but it wouldn't allow me to enter this as the IP.

If anyone has any advice it would be very much appreciated as at the moment the only solution seems to be to leave the PC turned on all day!

Many thanks.

kmr1962
Posts: 26
Joined: Mon Aug 15, 2011 5:20 pm

Re: Wake on LAN (WOL) Problems

Post by kmr1962 » Mon Jan 16, 2012 12:03 am

The web configuration for Wake On LAN is nothing to do with sending WOL packets from the internet
That web page is used to send a WOL (Magic) packet from the 7800n to the PC
To use this you would need to allow access from your current internet address (or go via a proxy) to the web interface of your router (Advanced settings -> Remote access).
Bothe of which would be a security risk. Or connect to the router via VPN, which would be more secure.

To send a wakeup from the internet the router would need to forward UDP Port 9 to the broadcast address (192.168.1.255) by default
Which you can't configure from the web interface (as you have found).

transparentdesigns
Posts: 3
Joined: Sat Jan 14, 2012 7:29 pm
Location: Brighton, UK
Contact:

Re: Wake on LAN (WOL) Problems

Post by transparentdesigns » Tue Jan 17, 2012 11:36 am

Many thanks for your reply, and thanks also for explaining what the Wake On Lan setting within the web configuration is for. I agree about the security risks of allowing access to the router remotely so would prefer not to.

So I'm clear on what I need to do - forward UDP 9 to the broadcast address. But as you said, you can't do this through the web interface. So does that mean it's basically impossible to achieve, or is there another way around it?

My previous two routers (both supplied by the ISP) didn't allow for WOL - which is why I was hoping the BiPAC would. Is wanting to wake up PCs remotely that uncommon an thing? If anyone can recommend a router that can definitely allow for it then that might be a solution.

kmr1962
Posts: 26
Joined: Mon Aug 15, 2011 5:20 pm

Re: Wake on LAN (WOL) Problems

Post by kmr1962 » Tue Jan 17, 2012 11:16 pm

I think if you add a static ARP entry for the PC that you want to wake up so that the router always knows which MAC address is associated with the IP address
As well as forwarding UDP port 9, that should work
You need the static arp entry because the arp table entry for the PC in the router will get flushed quite quickley when the PC is off.

But depending on the complexity of your LAN care would need to be taken using static ARP entries,
If you have more than 1 router/switch and you ever move the PC to a different switch/router the static ARP entry will need removing or you will have problems.
Basically you need to remember you have done it :)

Ether way give it a try, you can always undo the configuration changes (Or restore the backup that you take before making the changes).

transparentdesigns
Posts: 3
Joined: Sat Jan 14, 2012 7:29 pm
Location: Brighton, UK
Contact:

Re: Wake on LAN (WOL) Problems

Post by transparentdesigns » Wed Jan 18, 2012 9:52 pm

Thanks again for your continuing help.

I tried adding a static ARP entry but not luck. It just seems that the WOL magic packet won't get through. My LAN setup is very simple / basic - just a home setup really. The BiPAC is wired to the PC I want to be able to wake remotely, and via wifi to various other devices.

As mentioned, I can wake the PC from sleep using another device on the LAN - it just would have been really useful to be able to do it from outside. When it's switched on I can access via VNC from work - but I don't really want to leave it switched on all day. It's only from time to time that it's useful to be able to access it - so it would have been great to be able to wake it from sleep.

Is this just such a niche use that routers in general don't allow for it? If there are any you know that do work could you recommend them?

Kind Regards!

kmr1962
Posts: 26
Joined: Mon Aug 15, 2011 5:20 pm

Re: Wake on LAN (WOL) Problems

Post by kmr1962 » Wed Jan 18, 2012 11:39 pm

You will probably find that the WOL packet is not leaving the LAN at your work place (Switches, Firewalls, proxys generally block UDP Broadcasts)

Try sending the wake-up from this web site http://www.depicus.com/wake-on-lan/woli.aspx (Easiest option and most likley to work)

Or download the "stand alone" program from here http://www.depicus.com/wake-on-lan/wake-on-lan-gui.aspx

It definatly works, I setup the static ARP entry on my 7800n and tested it my self today.
I used the above web page to send the wakeup packet and set the netmask to 255.255.255.255

NickC4555
Posts: 1
Joined: Tue Apr 24, 2012 12:11 pm

Re: Wake on LAN (WOL) Problems

Post by NickC4555 » Tue Apr 24, 2012 12:19 pm

Joining in this a bit late, but I've just been having the same problem. I sorted it following the advice in this topic, but additionally, instead of having a static IP on the PC I used a Fixed Host entry in the DHCP settings (Advanced -> Configuration -> LAN -> DHCP Server -> Fixed Host).

In summary:

Static ARP entry
Port Forwarding
Fixed Host entry

sWi7zLe
Posts: 7
Joined: Tue Apr 24, 2012 1:04 pm

Re: Wake on LAN (WOL) Problems

Post by sWi7zLe » Thu Jun 05, 2014 4:01 pm

kmr1962 wrote:I think if you add a static ARP entry for the PC that you want to wake up so that the router always knows which MAC address is associated with the IP address
Thanks for that, this was the final piece to the puzzle ;)

I already had UDP port 9 forwarded and the MAC entered into the Wake On Lan page, but could not wake up my NAS remotely.

Now I can wake up my NAS via a phone app :D

Think I'll see if I can do the same for my PC now!

Cheers

lozabillionforum
Posts: 1
Joined: Tue Dec 27, 2016 6:08 am

Re: Wake on LAN (WOL) Problems

Post by lozabillionforum » Tue Dec 27, 2016 6:20 am

NickC4555 wrote:Joining in this a bit late, but I've just been having the same problem. I sorted it following the advice in this topic, but additionally, instead of having a static IP on the PC I used a Fixed Host entry in the DHCP settings (Advanced -> Configuration -> LAN -> DHCP Server -> Fixed Host).

In summary:

Static ARP entry
Port Forwarding
Fixed Host entry
Hi Nick any chance you can send a picture as mine says invalid entry.(see attached photo)
The IP address is already had entries in Incoming IP Filtering Setup and Nat /virtual server but the WOL is what I was interested about.I use RDP app to wake up the PC but don't wont to add WOL in as a Virtual server.
Thanks Loza
You do not have the required permissions to view the files attached to this post.

billion_fan
Posts: 5201
Joined: Tue Jul 19, 2011 4:30 pm

Re: Wake on LAN (WOL) Problems

Post by billion_fan » Wed Jan 04, 2017 12:40 pm

lozabillionforum wrote:
NickC4555 wrote:Joining in this a bit late, but I've just been having the same problem. I sorted it following the advice in this topic, but additionally, instead of having a static IP on the PC I used a Fixed Host entry in the DHCP settings (Advanced -> Configuration -> LAN -> DHCP Server -> Fixed Host).

In summary:

Static ARP entry
Port Forwarding
Fixed Host entry
Hi Nick any chance you can send a picture as mine says invalid entry.(see attached photo)
The IP address is already had entries in Incoming IP Filtering Setup and Nat /virtual server but the WOL is what I was interested about.I use RDP app to wake up the PC but don't wont to add WOL in as a Virtual server.
Thanks Loza

Have you setup a 'Interface Grouping' rule?? (I am assume you don't have the 7800N??)

If you have you need to change the 'Group Name' before clicking on the 'Static IP Lease List >> Add' button

Post Reply